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Ez-Architect Tutorial

Introduction
Welcome to Ez-Architect, an easy to use application designed for creating floor plans, building plans and any other

kind of diagram. It comes with a large library of objects such as doors, windows furniture etc. which you can easily

incorporate into your plans. There are also a large number of sample plans which you can modify for your own use.

Ez-Architect is a draw program, which means it is object based, not pixel based. You can create objects of various

shapes and move them around freely within your drawing. The size and orientation of objects can also be easily

modified. However, unlike paint programs, you cannot erase only a small part of an object.

Objects can also be grouped together and used as one object. In this way it easy to create a large variety of items, such

as furniture, stairways, doors etc and save them in the library for use in other drawings.

Ez-Architect has a large range of functions which make it easy to draw floor plans and many other plans and diagrams.

For example scale settings, rulers, grid lines, text input and manipulation features, dimension lines, color and pattern

editors, layers, and a wide variety of drawing tools.

Manual

Ez-Architect’s pdf manual can be displayed by selecting [Manual] from the [Help] menu. The manual contains detailed

explanations of the program’s functions and features.

Using a Touch-Screen

For hints on using a touch-screen instead of a mouse for drawing, see the separate file entitled “Touch Screen

Operation”.



Page - 2

Ez-Architect Tutorial

Getting Started

Installing Ez-Architect

(1) After downloading, open the zip file and copy its contents to your desktop.

(2) Open the folder and double click on the [setup] icon. This will start up the installer.

(3) Follow the on-screen instructions to install the program.

Starting up Ez-Architect

The installer will place an [Ez-Architect] icon on your desktop. Double-click this icon to start up the program.

Windows 7 users can also start up the application from the [Start] menu, while Windows 8 and 10 users can do so from

the application list.

The first time that Ez-Architect starts up it will display the dialog below.

If you are using a touch-screen or a high resolution monitor select “Large Palettes”. But if you are using a mouse on a

low to medium resolution screen it is recommended that you choose “Small Palettes.” This setting can be changed at

any time in the “Preferences” dialog, which can be opened from the “Options” menu.

Next click “OK” to open the main window.
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The Main Window

The window shown below will display on your screen. At the top of the window is the menu bar, and below this are

buttons for displaying various palettes, as well as buttons which are used for creating and displaying layers

Moving the mouse over tools and menu items will display a short explanation about that feature at the bottom of the

window.

Displaying the Palettes
Clicking on the Palette buttons will display the various palettes. The Tool palette contains all the tools you need to create drawings. The

Color palete is used to apply colors to objects, while the Pattern palette is used to apply patterns. The Lines palette lets you choose different

line types and thicknesses, and the Library palette makes it easy to open various libraries containing objects such as furniture to use in your

drawing. Palettes can moved by dragging with the mouse. To hide the palettes click the palette button again.

Layer Buttons
You can create and display different layers by clicking the layer buttons. The name of the layer you are currently drawing in (the active layer)

is displayed to the right of these buttons. The Base layer (B) button shows all the current layers and allows them to be edited.

Key Buttons
The Key buttons perform the same function as the Shit, Ctrl and Delete keys on the keyboard. When using a touch-screen this makes it

easier to perform some tasks which require using these keys. The Key Buttons only function when touched on a touch-screen, not when

clicked with a mouse. These buttons do not display when Small Palettes are selected. The Key Assist menu items can be used instead.

Menu bar Title bar

Key buttons

Drawing window

Layer buttonsPalette buttons

Active layer name

Moving the mouse over tools and menu items will dis-

play a short explanation about that feature here.

Displays the currently selected fill and line colors and patterns
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Chapter 2  Try It Out
The tool palette contains all the tools you need to create diagrams and plans.

Using the selector tool

When the selector tool is selected the mouse cursor displays as an arrow head. This tool is used to select objects, and

to change their size and shape. To select this tool left-click on the arrow head shaped icon at the top left of the tool bar.

NB: When drawing objects you can choose to draw by dragging the mouse, or by clicking the mouse twice. Choose

[Preferences] from the [Options] menu and click on your preferred option under [Drawing Method].

Drawing objects

(1) Move the cursor over the rectangle tool on the tool bar, and click the left button (left-click).

(2) Move the cursor to the drawing area of the window. The cursor will change to a cross.

(3) Position the cursor where you want to start the rectangle and, holding down the left mouse button move the cursor

until the rectangle is the size you want. (This is called dragging the mouse.) Then release the mouse button.

(4) Now try drawing a circle next to the rectangle, in the same way. Just choose the circle tool and drag the mouse to

draw it.

NB: Hold down the [Shift] key while dragging the mouse to create squares and perfect circles.

Selecting objects

(1) Click on the selector tool again and move the cursor over the rectangle and left-click on it. Little black squares

(called handles) wil display at the corners of the rectangle. This shows that the rectangle is now selected.

Selected object

NB: If you want to select a transparent object you have to click on the border lines in order to select it.

HandlesHandles

Rotation tool

45 degree/90 degree line tool

Rounded rectangle tool

Arc tool

Arc pie tool

Regular polygon tool

Freehand tool

Hollow wall tool

Continuous hollow wall tool

Door tool

Magnifier

Stamp

Selector tool

Text tool

Line tool

Rectamg;e tool

Circle tool

Arc tangent tool

Polygon tool

Closed curve tool

Wall tool

Continuous wall tool

Ruler tool

Library/Image tool

Eyedropper tool Duplicate

Vector text tool

Ruler tool
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(2) Now, while holding down the [Ctrl] key, left-click on the circle. It will become selected too.

Hold down the [Ctrl] key to select multiple objects

(3) To deselect the objects, click anywhere else within the window.

(4) Now let’s use the mouse to select multiple objects. Place the selector in the drawing area and drag the mouse. A

blue colored area will display. This is called the selection area. Move the mouse so that the selection area covers

the objects you want to select. When you release the mouse button all the objects selected will display handles at

their corners.

Drag the mouse to cover the objects you want to select

NB (1): You can select all the objects in your drawing by selecting [Select All] from the [Edit] menu, or by pressing the [Ctrl] key and the [A] key together.

NB (2): To deselect just one object click on that object while holding down the [Ctrl] key. ([Ctrl click])

Hold down the [Ctrl] key to deselect just one object
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Moving Objects

Objects can also be moved by using the selector tool.

(1) Left-click on the object you want to move using the selector tool. Now, while holding down the left mouse button

move the mouse (this is called dragging). The object will move together with the mouse. If multiple objects are

selected they will all move.

Click on the object                                        Drag with the mouse                                    Release the mouse button

Reshaping Objects

Objects can be reshaped using the selector tool.

(1) First create an object such as a rectangle or circle.

(2) Left-click on the object using the selector tool. Next, hold down the [shift] key and left-click on the object again. You

will notice the handles move a little. For some objects, like circles, the number of handles will increase.

(3) You can now change the shape of the object by dragging the handles with the mouse.

Before and after shots of a square and circle that have been reshaped.
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Changing the size of objects

The selector tool can also be used for changing the size of objects.

Left click on the object you want to change to select it. By dragging the handles that display you can resize the object.

You can also resize objects by clicking on a handle and then using the keyboard arrow keys.

Select the object and drag the handles to resize it.

NB : To resize objects to perfect circles or squares, hold the [shift] key down when resizing.

Deleting Objects

Select the object you want to delete and the press the [Delete] key. You can also select “Delete” from the “Edit” menu.

NB: You can also delete objects by selecting “Cut” from the “Edit” menu. In this case the object will be copied to the clipboard and can be pasted back again

into the drawing or another application.

Drawing a Floor Plan

In this section we will explain how to draw the simple floor plan of a small city apartment below.

If you already have Ez-Architect started up select “New” from the “File” menu to create a new drawing.

NB: This drawing will be done using the metric system. Before starting the Tutorial choose “Drawing Units”

from the “Layout” menu and set units to centimeters. Then choose “Drawing Scale” from the same menu and

set the scale to “1:100”.
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How To Set the Grid

Using the grid function makes drawing plans easier. Choose “Grid Spacing” from the “Layout” menu.

The Grid Spacing dialog

For this drawing example set both the “Horizontal spacing” and “Grid spacing” to 90 cm, then click “OK”. The ideal

setting will vary according to the scale you use and the dimensions of your plan. Next select “Show Grid” from the

“Layout” menu. Evenly spaced dots will display on the screen. Then choose “Snap to Grid” from the “Layout” menu.

Now all objects that you draw will be automatically sized to conform with the grid. ie all dimensions will be in multiples

of 90cm. If you are drawing a plan whose dimensions are all multiples of 100 cm, then setting the grid spacing to 100

will make it easy to draw walls etc. accurately.

Draw the Walls

Before drawing the walls, open the “Preferences” dialog in the “Options” menu and make sure that “Wall Ends” in the

“Wall Tool Options” is set to “Square”. This setting affects  how wall corners display.

(1) Select the “Continuous wall tool” from the tool bar. Then move the cursor to the drawing area. The cursor will

change into a cross.

                                                                      

Continuous wall tool icon                                  Cursor

(2)  First we will draw the outside walls. Move the cursor to the top left of the window and left-click the mouse once.

(Don’t hold the mouse down.)

Start drawing from here
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(3) Move the mouse downwards. The wall will be drawn as you move the mouse, staying in alignment with the grid.

Notice that the length and angle of the wall display as you draw.

(4) Keep moving the mouse down, and when the length of the wall reaches 720cm, left-click the mouse again. (Push

the left mouse button down and release it.)

Hint : If you make a mistake at any time, you can choose “Undo” from the “Edit” menu. Ez-Architect lets you perform unlimited undos.

(5) Now move the mouse to the right. Notice that a corner has been formed. When the length of this wall reaches

450cm, left-click the mouse once again.

(6) Now we draw the right wall by moving the mouse upwards, until the wall reaches a length of 720cm.

Start here
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(7) Finally, move the mouse to the left, back to the starting point, and right-click the mouse. (Press the right mouse

button down once and release it.) This tells the Continuous Wall Tool that you have finished.

Now you have drawn the outside walls with a few clicks of the mouse.

(8) Next we will use the wall tool to draw the internal walls. Click the “Wall Tool” icon on the tool bar.

                                                                               Wall Tool

(9) After selecting the wall tool move the mouse cursor to the end position of one of the internal walls shown in the

diagram below.

(10) Hold the left mouse button down and move the mouse. The wall will be drawn as you move the mouse. When the

mouse has reached the end position of the wall release the mouse button. Draw the remaining internal walls in the

same way.
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Turn Off the Grid

In drawing the remainder of the diagram it will be more convenient to have the grid turned off. Select “Snap to Grid”

from the “Layout” menu once again. The tick mark next to this item will be removed, indicating that the grid is no longer

on.

Save Your Drawing

Now that you have drawn the walls you should save your work. Select “Save” from the “File” menu. Because it is a new

file, you haven’t named it yet. A dialog which allows you to name the file and choose the location to save it will display.

After inputting the file name and navigating to the location where you want to save it, click the [Save] button. Once a file

has been saved, choosing “Save” from the File menu will overwrite that file, without displaying the dialog above. To

change a file’s name or location, choose “Save as” from the “File” menu.

Select a Door From the Door Library

Now you need doors to put on your floor plan. You can get doors which are ready to use from the door library.

Library bar

(1) Click on the “Door Library” icon on the library bar.

Door Library Icon
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(2) The library window will display.

(3) Find “Door 3” in the door objects displayed.

(4) Drag this door onto your drawing. (Using the selector tool, place the mouse cursor on the door, and while holding

down the left mouse button move the cursor onto your drawing.) You can also double-click (using the left mouse

button) on the door to copy it to the top left corner of your drawing.

(5) Click [Done] to close the library window.

Position the Door

Now use the selector tool to position the door on your floor plan.

Selector Tool

(1) Left-click on the selector tool. The cursor will change to an arrow.

(2) Left-click on the door (on the lines, not the white space) to select it. The handles will display.

(3) Now drag the door to the position shown by “A” in the diagram below.

You can also use the keyboard arrow keys to move objects.

Door 3
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Duplicate the Door

As we need more doors, let’s duplicate the one we just positioned.

(1) Left-click on the door using the selector tool to select it.

(2) Choose “Duplicate” from the “Edit” menu. A dialog with various duplication settings will appear. Check that the

number of duplicates is set to “1” and click [OK]. Another door will display next to the original one. (You can also

use the “Duplicate” tool on the tool bar to do the same thing.)

NB : If you hold down the [Ctrl] key and press [D], the object will be duplicated without showing the dialog.

(3) Drag the new door to position B in the diagram below.

(4) Duplicate the door once again, and place in position C in the diagram below.
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Rotate a Door

Next, change the orientation of a door by rotating it, before placing it on the floor plan.

(1) Select one of the doors and dupllicate it.

(2) Select the new door with the mouse, using the selector tool.

(3) Choose “Rotate 90 degrees Counter-Clockwise” from the “Arrange” menu.

(4) Move the door to position D in the diagram below.

Flip a Door

Next let’s use the “Flip” function.
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(1) Select the door you just positioned at D, and duplicate it.

(2) Select the duplicate door.

(3)  Select “Flip Vertical” from the “Arrange” menu.

(4) Move the flipped door to position E in the diagram below.

(5) Duplicate the door you just moved to E, and move it to F in the diagram below.
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Position the Remaining Door

Finally we need the slightly smaller door for the bathroom.

(1)  Select the “Door Library” icon on the library bar.  

(2)  Left-click on  “Door 4” in the library window.

(3) Drag the door onto the drawing and click [OK].

(4)  Select the door and choose “Rotate 90 degrees Counter Clockwise” from the “Arrange” menu. Then drag it to

position G in the diagram below.

Door 4
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Add A Window

(1)  Click on the “Window Library” icon in the library bar

(2) Find “Window 7” and drag it to the drawing.

(3)   Move the window to position H in the diagram below.

(4) We can use the same window object as a closet door. Duplicate it, and then, after rotating it 90 degrees, place it in

position I in the diagram below.

Window 7
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Add Some Furniture

Now that the apartment is finished you can add furniture and fixtures. Use the libraries in the library bar to add the items

that you want.

The Text Tools

To finish up we want to add some text. We can use the text tools to do this. Ez-Architect has two text tools, the regular

text tool and the vector text tool.

                                               Text Tool       Vector Text Tool

These two tools are used in the same way. The biggest differences between the two types of text is that vector text can

be resized with the mouse like other objects, and can also be rotated.

(1) Select the text tool by clicking on it with the mouse.

(2) Left-click on the drawing where you want to input the text. A blinking text cursor will display.

(3) Input the text.

The font, text size, style etc. can be set by choosing “Font” from the “Text” menu. A normal Windows font dialog will

display. New text will follow the settings that are set in this dialog. To change the settings of existing text, select the text

and then choose “Font” from the “Text” menu to display the font dialog.

The color and pattern of the text and text background can be set using the color and pattern palettes, just like other

objects. Initially the text background is set to white, so if you want to see objects behind the text you have to change the

text background to transparent.

(1) Select the text by left-clicking on it with the mouse. Click the Pattern button at the top of the window to display the

Pattern palette.

(2) Left-click on the transparent pattern in the pattern palette.

Click here
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To change the color or pattern of the text itself, right-click on the color or pattern palette.

If you want to add more than a few of words of text, instead of left-clicking with the mouse, drag the mouse to define the

area you want  the text to display in. A text box will display. The text you input will be confined to this box. If you input

more text than will fit in the box, a dialog will display asking you to enlarge the text box. You can do this by selecting the

text box using the selector tool, and then dragging the handles.

Texture

You can also add texture to text.

(1)  Select the text.

(2) Choose “Object Properties” from the “Options” menu.

(3) Click the [Texture] button and then the [Assign Texture] button.

(4) Choose the texture you wish to use from the texture libraries that display, and click [Open]

(5) The texture will be displayed in the “Texture” dialog. You can adjust the size and rotation of the texture using the

controls.

(6) Click [OK] and then [OK] again.

Adding textures to other objects can be done in the same way.

Adding Colors and Patterns to Objects and Lines

To change the color or pattern of an object, select the object and then left-click on the color or pattern palette.

To change the color or pattern of the boundary line of an object, select the object and then right-click on the color or

pattern palette.

To change the color or pattern of a line, select the line and then right-click on the color or pattern palette.

Editing Colors and Patterns

Double clicking on a color or pattern in the Color and Pattern palettes will display an edit dialog which lets you edit and

save patterns and colors.


